2016-04-11 1 views
1

Funktioniert pdfkit mit grunt-browserify? Ich bin versucht zu Draht PDFKit mit einem Winkel einzigen Seite app aber mir immer die folgenden Fehler während meines Build-Prozesses:Ist pdfkit kompatibel mit grunt-browserify?

Running "browserify:dist" (browserify) task 
TypeError: Arguments to path.resolve must be strings 
Warning: Error running grunt-browserify. Used --force, continuing. 
TypeError: Arguments to path.resolve must be strings 
Warning: Error running grunt-browserify. Used --force, continuing. 
Fatal error: Callback was already called. 

Irgendwelche Ideen? Ich habe bereits benötigt für brfs und Puffer.

+0

Mein Problem wurde selbst verursacht. Ich hatte ein paar zusätzliche Quelldateien an einem anderen Ort, die die Fehler verursachten. Also war pdfkit nicht das Problem. Ich habe PDFKit jetzt in Betrieb. – whatsTheDiff

Antwort

2

Stellen Sie sicher, dass sich die Attribute in Ihrer package.json in Zeichenfolgen befinden und dass Sie einen Verzeichnisnamen und keinen Dateinamen übergeben.