2016-01-06 3 views
5
  1. Ich probiere die google places sdk Probe aus. Ich installierte es

pod versuchen Googlemaps mitSo erhalten Sie das neueste GoogleMaps SDK mit Pods

  1. Ich installierte Googlemaps (1.10.5) mit cocoapods

Quelle ' https://github.com/CocoaPods/Specs.git '

Plattform: ios,' 8.1 '

pod 'Googlemaps'

die Googlemaps in beiden Schritten, die man in der Probe überprüft (1) mehr Header wie GMSAutocompleteTableDataSource.h enthält

enter image description here

Warum sind sie anders? Der eine in der Probe scheint eine bessere Version zu sein, aber der von den Pods ist nicht der letzte? Es ist nicht einmal in der changelog

Antwort

3

überprüfte ich die neueste podspec

ich, müssen nur die Version auf die neueste

zB

pod 'Googlemaps' set ‚~> 2.5. 0 '

9

Führen Sie pod update GoogleMaps. Cocoapods aktualisiert die Version eines Pods, die Sie bereits heruntergeladen haben, nur, wenn Sie explizit pod update ausführen oder podspec aktualisieren, um eine neuere Version zu benötigen. Weitere Details finden Sie unter https://guides.cocoapods.org/using/pod-install-vs-update.html.

+0

Ich lief 'Pod Update GoogleMaps'. Dies aktualisiert nur die aktuelle Version. Aber als ich 'pod update' ausgeführt habe, wurde es von 2.2 auf 2.3.0 aktualisiert. Aber mein xcode meldet immer noch, dass eine neuere Version 2.3.3 existiert. Ich denke, ich werde 'pop update GoogleMaps' erneut ausführen. – Siddharth

0

In der Poddatei meines Projekts gibt ich die Version nicht an. Die Schote Zeile gibt nur: pod ‚Googlemaps‘

Also, wenn Sie die Version in der podfile nicht enthalten, dann den folgenden Befehl in einem Terminal-Fenster auf die neueste Version aktualisieren: pod ‚Googlemaps‘

Bitte stellen Sie sicher, dass Sie sich in dem richtigen Ordner befinden, der Ihre Poddatei enthält, bevor Sie diesen Befehl eingeben.

Es kann eine Weile dauern, bis Pod verarbeitet wird, wenn diese Nachricht angezeigt wird: Aktualisieren lokaler Repositorys.

Haben Sie geduldig - es dauerte ungefähr 20 Minuten.

Verwandte Themen