2010-03-02 3 views
17

Wie wirklich sehr langsam.Visual Studio langsam in Virtualbox

Ich habe einen 64 Bit, 8 Kerne, 12 Gig ram Windows 7 Host. Ich gab 4 Kerne und 4 Gigs RAM zu einem 64-Bit-Windows 7 virtuelle Maschine, in dem ich versuche, Visual Studio 2010 (und SQL Server - aber das ist es).

Es funktionierte für ein paar Tage, aber dann ging die Ressourcennutzung aus den Charts - fast 100% CPU zu jeder Zeit. Ich habe die visuellen Effekte von Windows 7 ausgeschaltet und es fiel sofort auf normale Werte. Aber jedes Mal, wenn ich versuche, etwas im Visual Studio zu tun, spitzt es sofort wieder zu.

Hat jemand mit einem ähnlichen Rig eine ähnliche Erfahrung? Ich weiß, dass die Leute dieses Setup erfolgreich abgeschlossen haben und sehr zufrieden damit sind. Ich frage mich, ob ich irgendwo eine schlechte Konfiguration habe.

+0

Ich habe die gleiche Maschine und die gleiche deaktivieren Problem. Ich habe festgestellt, dass die VM im Laufe der Zeit immer langsamer wird, weshalb ich sie oft neu starte - das hilft eine Weile. Es spielt keine Rolle, ob ich einen oder mehrere Kerne verwende. –

+0

Das passiert mir auch auf dieser Maschine. Auf meinem viel langsameren Laptop tut es das nicht. –

Antwort

11

Found a clue here.

Es scheint, dass virtualbox 3.1.4 (meine aktuelle Version) ausflippt, wenn Sie ihm sagen, mehr als eine CPU unter Windows 7 zu verwenden. Ich legte es auf 1 CPU statt 4 und Ressourcenverbrauch ging wieder normal .

Hoffe, dass sie das bald beheben.

+4

Um fair zu sein, ist es immer noch wahnsinnig langsam. Einfach besser –

+0

Das hat bei mir nicht funktioniert – Thiru

+0

Das machte einen großen Unterschied. Windows 7 unter OS X Yosemite/Virtuelle Box/Visual Studio Express 2013. 4 Kerne -> 1. –

15

Visual Studio 2010 verwendet GPU-Beschleunigung, um seine GUI zu verwenden, da es WPF für seine Formulare verwendet. VMs gehen GPU-Aufgaben nicht so effizient durch. In VS gehen Sie zu Extras -> Optionen -> Umgebung -> Allgemein -> Visuelle Erfahrung und deaktivieren Sie die 3 Kontrollkästchen in diesem Feld und sehen, ob das den Trick macht.

Ich habe festgestellt, VMs werden manchmal gut mit Aero und VS 2010 mit der GPU funktionieren, aber dann ohne Grund genau das getan, was Sie beschreiben. Das funktioniert für mich.

+0

Danke für den Tipp. Alle Kontrollkästchen sind deaktiviert, haben aber immer noch Probleme. Irgendwelche anderen Ratschläge? –

+0

Nein :(Das ist immer für mich getan, obwohl ich normalerweise Parallels oder VMware Fusion verwende, da ich OS X als Host verwende. Welche VM-Software verwendest du? – jamone

+0

... virtualbox ... –

4

Deaktivieren der 3D-Beschleunigung unter VM-Einstellungen hat den Trick für mich getan.

4

Meine aktuellen Einstellungen sind:

  • deaktiviert 3D-Beschleunigung
  • deaktiviert Remote Display Server
  • nur 1 CPU

Die VS 2010 Geschwindigkeit nicht excelent ist aber auch nicht so langsam.

+0

Bei der Installation von VS2013 lief die Installation furchtbar langsam. Darüber hinaus habe ich meinen VM-Speicher auf 6 GB eingestellt; Das schien das Problem zu lösen, das ich erlebe. –

Verwandte Themen