2015-02-10 2 views
6

Aus dem Symfony Buch http://symfony.com/doc/current/book/security.html#security-authorization Ich versuche, die grundlegende http-Authentifizierung einzurichten.Symfony Sicherheit grundlegende Authentifizierung

Die security.yml Datei sieht wie folgt aus:

security: 
    providers: 
     in_memory: 
      memory: ~ 

    firewalls: 
     dev: 
      pattern: ^/(_(profiler|wdt|error)|css|images|js)/ 
      security: false 

     default: 
      anonymous: ~ 
      http_basic: ~ 

     access_control: 
      - { path: ^/login, roles: ROLE_USER } 

Aber sobald ich

access_control: 
     - { path: ^/login, roles: ROLE_USER } 

füge ich einen symfony Fehler bekommen sagen:

InvalidConfigurationException in ArrayNode.php line 309: 
Unrecognized option "0" under "security.firewalls.access_control" 

Was mache ich falsch ? Was zu tun, um es zu beheben?

Antwort

22

Ihr Einzug ist nicht gut

access_control Schlüssel nicht unter firewalls Knoten bleiben

Sie sollten Ihre security.yml wie folgt ändern

security: 
    providers: 
     in_memory: 
      memory: ~ 

    firewalls: 
     dev: 
      pattern: ^/(_(profiler|wdt|error)|css|images|js)/ 
      security: false 

     default: 
      anonymous: ~ 
      http_basic: ~ 

    access_control: 
     - { path: ^/login, roles: ROLE_USER } 
+0

oooh danke @DonCallisto! Jetzt weiß ich, dass Whitespace in '.yml'-Dateien auch wirklich eine Rolle spielt! Will annehmen, sobald ich kann – caramba

+1

@ Caramba: Natürlich sind sie wichtig, sonst Datei kann nicht geparst werden – DonCallisto

1

Denken Sie daran, dass, wenn Sie benötigen ROLE_USER zu Ihr /login Pfad kann dann ein nicht autorisierter Benutzer nicht in Ihre App einloggen.

Verwandte Themen