2012-07-01 1 views
5

In dem Thema, das ich für vim verwende, werden die Strings in roter Farbe angezeigt, aber das Problem ist, dass ich die Rechtschreibprüfung aktiviert habe und die falsch geschriebenen Wörter ebenfalls in roter Farbe angezeigt werden.Wie ändert man die Farbe des hervorgehobenen falsch geschriebenen Wortes?

Dies macht es schwierig zu sehen, was der Fehler ist, bis Sie zu diesem Wort gehen und jedes Zeichen löschen.

Ich möchte die Hervorhebung des falsch geschriebenen Wortes in etwas heller als es derzeit machen. Sag # ff2929.

                                                                                                              You can't see what is the misspelled word

+0

Vor langer Zeit, als ich diese Frage gepostet habe, habe ich für meine Shell solarisiertes Farbschema gefunden. –

+0

Ich benutze Solarized selbst, versuchen 'markieren Pmenu ctermbg = dunkelrot ctermfg = weiß guibg = schwarz gui = fett 'sehen, ob das das Problem behoben. Natürlich setze die Hintergrundfarbe nach [hier] (https://github.com/altercation/vim-colors-solarized) –

Antwort

9

Sie können in Ihrer ~/.vimrc die hi (kurz für :help highlight) Befehl verwenden. Die allgemeine Struktur ist:

hi SpellBad ctermfg=015  ctermbg=000  cterm=none  guifg=#FFFFFF guibg=#000000 gui=none 

Die cterm ist für die Klemme und die Vim gui ist für gVim. Die fg steht für Vordergrund und ist die Farbe der Buchstaben und die bg steht für Hintergrund und ist die Farbe hinter den Buchstaben.

Terminal Farben können 0-15 für Standard Terminal Farben (8 normal und 8 hell) oder 0-255 für Begriffe, die 256 Farben, wie Xterm-256colors unterstützen. Die gui Farben sind im hexadezimalen Format. xterm-color-table ist eine nützliche Referenz für 256 und hexadezimale Farben. Die letzte Option kann verwendet werden, um fett, italic, oder keine (keine) anzugeben.

In Ihrem Fall ist es am einfachsten, den Vordergrund auf Schwarz zu setzen, um die Buchstaben hervorzuheben. Suchen Sie zuerst nach einem Wort, das mit :set spell falsch geschrieben wurde, und geben Sie dann asdflkjasldf oder etwas ein. Dann geben Sie :hi SpellBad ctermfg=000 guifg=#000 ein und sehen Sie, ob das eine Lösung ist, die Ihnen gefällt. Wenn nicht, verwenden Sie die xterm-Farbtabelle oder eine andere Farbreferenz, um eine Farbe zu finden, die Ihnen gefällt.

5

Versuchen Sie folgendes:

:hi SpellBad guibg=#ff2929 ctermbg=224 
  • guibg ist für GUI
  • ctermbg für TERM ist
+0

Ich benutze vi in ​​Gnome-Terminal, nichts funktioniert, wenn ich tue ': hi SpellBad guibg = # ff2929' und wenn ich 'ctermbg = 224' anhefte, glaube ich nicht, dass die Rechtschreibprüfung funktioniert (kein Wort ist hervorgehoben, sogar falsch geschrieben!) –

+0

Probieren Sie einen anderen Farbcode aus. Nein, jedes Terminal ist gleich. – kev

Verwandte Themen