2016-05-19 1 views
3

Ich benutze Foundation 6 Zurb Template mit Flexbox aktiviert und die erweiterte Funktion der Schaltflächengruppe funktioniert nicht.Foundation 6 Button Group Expanded funktioniert nicht

Wenn ich die erweiterte Klasse hinzufüge, füllt die letzte Schaltfläche das letzte Leerzeichen nicht und wird in der nächsten Zeile auf der linken Seite angezeigt. Der Text ist nicht mehr inline und die Breite der Schaltflächen ist nicht identisch.

<div class="expanded button-group"> 
    <a class="button">Expanded</a> 
    <a class="button">Button</a> 
    <a class="button">Group</a> 
</div> 

Irgendeine Idee, was könnte falsch sein? Tnx!

Antwort

1

Es funktioniert mit Foundation 6.2.1, welche Version verwenden Sie?

siehe CodePen Beispiel. http://codepen.io/shoaibik/pen/VaJbvj

+0

Dank Shoaib, wenn ich den genauen Code in meinem Build steckt es nicht funktioniert. Ich glaube, ich benutze 6.2.1 (heruntergeladen über CLI vor 3 Wochen). Die Datei bower.json hat jedoch folgenden Code: "Abhängigkeiten": { "Grundbausteine": "~ 6.2.0", "motion-ui": "~ 1.2.2" }. Wissen Sie, ob ich die Foundation 6 Version von Zurb Template über die CLI aktualisieren kann? Wenn ja, irgendeine Idee wie? Tnx! – RCD

+0

ändere 'foundation-sites": "~ 6.2.0" 'zu' foundation-sites ":" ~ 6.2.1 "' und führe 'bower update' aus und überprüfe nochmals, ob das funktioniert. –

+0

Nicht sicher, ob es tatsächlich aktualisiert wurde, und keine Änderung mit Schaltflächengruppe erweitert Problem. Jemand anderes sagte, dass das '~' vor 6.2.0 bedeutet, dass es automatisch auf die neueste Version aktualisiert wird. Bower zwischengespeichert https://github.com/urzb/foundation-sites.git#6.2.1 Bower validieren 6.2.1 gegen https://github.com/zurb/foundation-sites.git#~6.2.1 Bower zwischengespeichert https://github.com/jquery/jquery-dist.git#2.2.4 Bower validieren 2.2.4 gegen https://github.com/jquery/jquery-dist.git#~2.2.0 Bower Installation Foundation-Sites # 6.2.1 – RCD

Verwandte Themen