2016-08-09 1 views
1

enter image description here Ich verwende Highcharts 4.2.5. Die Bereichsauswahl wird teilweise angezeigt. Die Felder & bis date werden nicht angezeigt, aber manchmal, wenn ich die Seite vergrößere, sehe ich die Datumsfelder, aber das Datumsfeld ist nur lesbar. Eine weitere Beobachtung, ich sehe das Datumsfeld, wenn die Diagrammbreite groß ist. Bei mehreren Liniendiagrammen kommt das Datum jedoch nicht.Highcharts - Range Selector - Datumsfelder nicht sichtbar

enter image description here

enter image description here

Im Folgenden finden Sie meine Optionen

{ 
"tooltip" : { 
    "useHTML": "true", 
    "headerFormat" : "{point.key}<br>" 

}, 

"credits" : { 
    "enabled" : true 
}, 
"navigator" :{ 
    "enabled": true 
}, 
"scrollbar" :{ 
    "enabled": true 
}, 

"rangeSelector" : { 
    "allButtonsEnabled" : true 
}, 

"legend" : { 
    "enabled" : true 
}, 
"title" : { 
    "text" : "" 
}, 

"series" : [] 
} 
+0

können Sie den Link zu js Geige/codepen, damit wir Ihnen besser helfen können. – Strikers

+0

Dies ist in der http://jsfiddle.net/gh/get/jquery/1.9.1/highslide-software/highcharts.com/tree/master/samples/stock/demo/compare/ replizierbar, beachten Sie, dass, wenn Sie reduzieren die Rahmengröße verschwindet das Datumsfeld, aber wenn Sie es erweitern, kommt es zurück. – ZEE

+1

Hallo ZEE, es ist normal, dass manchmal Eingabefelder nicht sichtbar sind - es ist, weil sie beginnen, mit Schaltflächen zu überlappen. Möchten Sie diese Eingabefelder immer sichtbar haben? Sie können in diesem Fall rangeSelector.inputEnabled: true verwenden. –

Antwort

2

Eingang zeigt, wenn das Diagramm genügend Platz hat, sonst wird der Eingang versteckt. Wenn Sie die Eingabe immer aktivieren möchten, müssen Sie sie in den Optionen festlegen.

rangeSelector: { 
      enabled: true, 
      inputEnabled: true 
     }, 

Beispiel: http://jsfiddle.net/bnmb05eu/

+0

Ich habe "inputEnabled" aktiviert: true, aber das Feld von und bis zum Datum ist schreibgeschützt. – ZEE

+0

Können Sie auf mein Beispiel verweisen? Wie ist die Box nur lesbar? – morganfree

+0

Die Box in Ihrem Beispiel ist nicht readonly, aber es ist in readonly-Modus in meinem. wenn ich auf das Feld klicke, funktioniert es nicht. Ich habe einen neuen Screenshot hinzugefügt, in dem Sie das Über-Datum-Feld überlappen sehen und es nur lesen. – ZEE