2016-11-22 1 views
0

EDIT2: APC ist installiert und aktiviert. Was wäre die Lösung?fsockopen() Fehler 500, wenn ich nach der Bereitstellung auf Ubuntu VPS auf meine Symfony App zugreife

Ich versuche, eine Symfony App auf einem VPS bereitzustellen. Ich habe den Code von git ok bereitgestellt, ich habe Anbieter installiert und check /web/config.php, um alle wichtigen und empfohlenen Probleme der Symfony-Anforderungen zu beheben. Es ist alles grün.

Allerdings, wenn ich versuche, auf die [VPS_IP] /my_project/web/app.php zuzugreifen, bekomme ich eine Seite funktioniert nicht. [my_ip] kann die Anfrage derzeit nicht verarbeiten.

Ich habe auch versucht, virtuellen Host zu konfigurieren und versuchen, auf meine Symfony App auf dem [my_ip] nur als URL-Adresse zuzugreifen und ich bekomme das gleiche Ergebnis.

Ich habe Apache 2 Mod Rewrite aktiviert, ich habe alle notwendigen PHP-Erweiterungen hinzugefügt und aktiviert, ich habe date.timezone in php.ini eingestellt, ich habe auch in den dev.log-Dateien und tehre nachgesehen Ich habe diesen Fehler, der die Ursache sein kann:

[2016-11-22 14:45:49] php.DEBUG: fsockopen(): unable to connect to 127.0.0.1:800   0 (Connection refused) {"type":2,"file":"/var/www/html/giftbundle/vendor/symfony   /symfony/src/Symfony/Bundle/FrameworkBundle/Command/ServerCommand.php","line":59   ,"level":28928} [] 

Könnte jemand Hilfe bieten?

config.yml

imports: 
    - { resource: parameters.yml } 
    - { resource: security.yml } 
    - { resource: services.yml } 
    - { resource: "@MyVendorBundle/Resources/config/services.yml" } 

# Put parameters here that don't need to change on each machine where the app is deployed 
# http://symfony.com/doc/current/best_practices/configuration.html#application-related-configuration 
parameters: 
    locale: en 

framework: 
    #esi:    ~ 
    #translator:  { fallbacks: ["%locale%"] } 
    secret:   "%secret%" 
    router: 
     resource: "%kernel.root_dir%/config/routing.yml" 
     strict_requirements: ~ 
    form:   ~ 
    csrf_protection: ~ 
    validation:  { enable_annotations: true } 
    serializer:  { enable_annotations: true } 
    templating: 
     engines: ['twig'] 
     #assets_version: SomeVersionScheme 
    default_locale: "%locale%" 
    trusted_hosts: ~ 
    trusted_proxies: ~ 
    session: 
     # handler_id set to null will use default session handler from php.ini 
     handler_id: ~ 
     save_path: "%kernel.root_dir%/../var/sessions/%kernel.environment%" 
    fragments:  ~ 
    http_method_override: true 
    assets: ~ 

# Twig Configuration 
twig: 
    debug:   "%kernel.debug%" 
    strict_variables: "%kernel.debug%" 
    form_themes: 
     - 'bootstrap_3_layout.html.twig' 

# Doctrine Configuration 
doctrine: 
    dbal: 
     driver: pdo_mysql 
     host:  "%database_host%" 
     port:  "%database_port%" 
     dbname: "%database_name%" 
     user:  "%database_user%" 
     password: "%database_password%" 
     charset: UTF8 
     # if using pdo_sqlite as your database driver: 
     # 1. add the path in parameters.yml 
     #  e.g. database_path: "%kernel.root_dir%/data/data.db3" 
     # 2. Uncomment database_path in parameters.yml.dist 
     # 3. Uncomment next line: 
     #  path:  "%database_path%" 

    orm: 
     auto_generate_proxy_classes: "%kernel.debug%" 
     naming_strategy: doctrine.orm.naming_strategy.underscore 
     auto_mapping: true 

# Swiftmailer Configuration 
swiftmailer: 
    transport: "%mailer_transport%" 
    host:  "%mailer_host%" 
    username: "%mailer_user%" 
    password: "%mailer_password%" 
    spool:  { type: memory } 

# app/config/config.yml 
#knp_menu: 
    # use "twig: false" to disable the Twig extension and the TwigRenderer 
# twig: 
#  template: knp_menu.html.twig 
    # if true, enables the helper for PHP templates 
# templating: false 
    # the renderer to use, list is also available by default 
# default_renderer: twig 

assetic: 
    debug:   '%kernel.debug%' 
    use_controller: '%kernel.debug%' 
    filters: 
     cssrewrite: ~ 

gregwar_captcha: ~ 

liip_imagine: 
    filter_sets: 
     cover_filter: 
      filters: 
       thumbnail: 
        size: [600, 400] 
        mode: inset 
     prod_thumbnail: 
      filters: 
       thumbnail: 
        size: [50, 50] 
        mode: inset 

#web_profiler: 
# toolbar: true 
# position: bottom 
# intercept_redirects: false 
# excluded_ajax_paths: ^/bundles|^/_wdt  

parameters.yml

# This file is auto-generated during the composer install 
parameters: 
    database_host: [another remote DB IP] 
    database_port: 3306 
    database_name: [remote DB name] 
    database_user: [Remote DB user] 
    database_password: [remote DB PSW] 
    mailer_transport: sendmail 
    mailer_host: 127.0.0.1 
    mailer_user: null 
    mailer_password: null 
    secret: rodacsoft 
    facebook_app_id: [fb_app_ID] 
    facebook_app_secret: [fb_secret] 

VPS /etc/apache2/sites-available/000-default.conf

<VirtualHost *:80> 

    DocumentRoot /var/www/html/giftbundle/web 
    <Directory /var/www/html/giftbundle/web> 
     AllowOverride None 
     Order Allow,Deny 
     Allow from All 

     <IfModule mod_rewrite.c> 
      Options -MultiViews 
      RewriteEngine On 
      RewriteCond %{REQUEST_FILENAME} !-f 
      RewriteRule ^(.*)$ app.php [QSA,L] 
     </IfModule> 
    </Directory> 

    # uncomment the following lines if you install assets as symlinks 
    # or run into problems when compiling LESS/Sass/CoffeScript assets 
    # <Directory /var/www/project> 
    #  Options FollowSymlinks 
    # </Directory> 

    ErrorLog /var/log/apache2/symfony_error.log 
    CustomLog /var/log/apache2/symfony_access.log combined 
</VirtualHost> 

EDIT: in der Symfony_error.log Ich habe das. Keine Ahnung, wie es zu beheben ist oder ob es verwandt ist.

[Tue Nov 22 14:46:06.216187 2016] [:error] [pid 21788] [client 159.153.60.77:18035] PHP Fatal error: Uncaught Symfony\\Component\\DependencyInjection\\Exception\\ServiceNotFoundException: The service "validator.builder" has a dependency on a non-existent service "validator.mapping.cache.apc". in /var/www/html/giftbundle/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/CheckExceptionOnInvalidReferenceBehaviorPass.php:58\nStack trace:\n#0 /var/www/html/giftbundle/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/CheckExceptionOnInvalidReferenceBehaviorPass.php(51): Symfony\\Component\\DependencyInjection\\Compiler\\CheckExceptionOnInvalidReferenceBehaviorPass->processReferences(Array)\n#1 /var/www/html/giftbundle/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/CheckExceptionOnInvalidReferenceBehaviorPass.php(51): Symfony\\Component\\DependencyInjection\\Compiler\\CheckExceptionOnInvalidReferenceBehaviorPass->processReferences(Array)\n#2 /var/www/html/giftbundle/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/CheckExceptionOnIn in /var/www/html/giftbundle/vendor/symfony/symfony/src/Symfony/Component/DependencyInjection/Compiler/CheckExceptionOnInvalidReferenceBehaviorPass.php on line 58 
+0

Aus dem Fehlerprotokoll, denke ich, dass Ihr Symfony-Projekt APC-Cache aktiviert hat, und Ihr Server hat keinen apc-Cache installiert –

+0

@Szanto apcache ist aktiviert, was ich in phpinfo sehe. Wie würde ich das beheben? Ich ändere den Symfony App Cache, den es benutzt, um mit etwas anderem zu arbeiten, falls mein Server etwas anderes als was ich denke? –

+0

@ SzántóZoltán Oder noch besser, wie konfiguriere ich Symfony, um Server Memcache zu verwenden? –

Antwort

0

Überprüfen Sie, ob der Cache-Ordner vom Benutzer apache (www-data) beschreibbar ist. Sie können nicht auf [VPS_IP] /mein_projekt/web/app.php zugreifen, weil Sie den Web/Ordner bereits als Stammordner in Apache Config definiert haben. Sie sollten ServerName und ServerAlias ​​in Apache Config mit Ihrem Domainnamen definieren oder direkten Zugriff auf [VPS_IP] /app.php versuchen. Geben Sie auch Ihre IP-Adresse in app_dev ein und greifen Sie auf [VPS_IP] /app_dev.php zu, um weitere Fehler zu finden.

+0

Cache-Ordner ist beschreibbar, ich löste Berechtigungen. Ich habe es auch mit IP und nicht mit Webordner versucht, da ich meinen virtuellen Host konfiguriert hatte. Gleiches Problem. Ich werde versuchen, app_dev.php zu überprüfen, aber dafür geben Sie mir Informationen, wenn Anbieter mit --no-dev installiert sind? –

+0

Ich habe app_dev.php hinzugefügt und wenn ich darauf zugreife, lädt die Seite, aber ohne Formatierung und Assets, obwohl sie im Webordner vorhanden sind. Also, warum funktioniert es nicht ohne app_dev? –

+0

Ich habe den Dokumentstammpfad korrigiert und die Assets werden in app_dev geladen.PHP, aber wenn ich versuche, regelmäßig für prod zuzugreifen, bekomme ich, dass ** Seite nicht funktioniert. [my_ip] kann die Anfrage derzeit nicht bearbeiten. ** –

Verwandte Themen