2016-05-19 1 views
1

Sublime Text 3 hat diese wirklich lästige Angewohnheit, meine Kommentare automatisch zu vervollständigen, nachdem ich sie bereits geschlossen habe. Also, wenn ichSublime Text 3 Kontextergänzung deaktivieren

/*|*/ 

schreiben, wo die Bar mein Cursor ist, und dann auf die Registerkarte I drücken, so dass ich eine Vertiefung im Anschluss an meine Anfangs * Symbol setzen, möchte ich es wie folgt aussehen:

/* |*/ (assume that the bar is my cursor and tab of size 4 between *s) 

Stattdessen bekomme ich dies:

/* 
| 
*/*/ 

Dies ist extrem ärgerlich; Ich mag es, meine Kommentare so anzupassen, dass sie zu der Rechnung passen, an der ich gerade arbeite. Ich weiß, dass ich eine Präferenz/Paket in meinen Benutzereinstellungen ignorieren kann, aber ich weiß nicht, welche zu ignorieren. Dies ist ein obskurer Kontext und ich kann nicht finden, welche Option es auslöst. Idealerweise möchte ich für andere Dinge automatisch vervollkommnen, aber es ist nicht etwas, auf das ich mich stark vertraue, also wäre es kein großer Verlust, es dabei zu verlieren.

BEARBEITEN - Tipps zum Entfernen von automatisch kommentieren, wenn ich 'Enter' auf einem "//" Kommentarzeile drücken wäre auch nett. Was Ich mag würde

// 
| 

ist und was ich (frustrierende) erhalten ist

// 
//| 
+0

Um zu klären: die Autovervollständigung Popup nicht, aber es fügt automatisch etwas, wenn Sie Tab drücken? Und Sie möchten dieses Verhalten deaktivieren? –

+0

@ r-stein Ja, genau das ist es. Es zeigt mir die eingehende Änderung nicht an, aber führt sie aus, wenn ich trotzdem Enter drücke. –

Antwort

1

Ich kann keine Bilder hinzufügen, Sie müssen also auf den Link klicken;

find docblockr settings

add setting

"jsdocs_extend_double_slash": false

// 
//| 

Sie erhalten können, ist

// 
| 

Weitere Einstellungen; Sie müssen die Datei anzuzeigen: Einstellungen-> Package Einstellungen-> DocBlockr-> Einstellungen-Standard

+0

Es ist seltsam, es gibt keine Option, um Kommentarblöcke zu deaktivieren (die "/ * * /" Blöcke). Danke dafür aber, stellte mir den DocBlockr und einige seiner Tricks vor, die ich generell mag! –

0

Dieses Verhalten wird durch das DocBlockr Paket verursacht wird, enthält es eine keymap, dass die eingeben Schlüssel bindet erstellen ein Snippet, wenn es sich in einem Kommentarbereich befindet. Die Lösung besteht darin, dieses Paket zu deinstallieren.

+0

Das ist bedauerlich, da DocBlockr eine Reihe anderer wirklich netter Funktionen hat und im Allgemeinen sehr nützlich ist. Danke für die Info! –

1

Als Ergänzung zu @baijunyao ‚s answer: einen kurzen Blick in die keymap DocBlockr nehmen sie zum Einfügen \n*/ keine Einstellungen überprüfen wenn Sie tab drücken. Allerdings können Sie leicht eine Keybinding zu Ihrem Key Bindings - User hinzufügen:

{ 
    "keys": ["tab"], "command": "insert", "args": {"characters": "\t"}, "context": 
    [ 
     { "key": "selector", "operator": "equal", "operand": "comment" } 
    ] 
}, 

Dieses Keybinding ausgedrückt werden könnte, wie „Wenn ich tab drücken, und ich bin in einem Kommentar, dann eine Registerkarte einzufügen.“.

+0

Das hat den Trick gemacht! Ich bin immer noch nicht vertraut mit der Grammatik von erhabenen - <> Dateien und dergleichen, sehr geschätzt! –

0

Ein alternativer Weg zu drücken Shift + .
Es erlaubt, alle Ereignisse als Auto-Vervollständigung-Trigger zu ignorieren und einfach einen Einrückungsraum zu schreiben.

Verwandte Themen